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Have you ever written a long paper and then found one more reference that really 
should be included in the first paragraph?  Thirty references to renumber!  Haven't 
you ever wished that your computer could renumber those references?  Scholar's 
Aid  lets your Mac do that and more.
Scholar's Aid  searches your text for figure, table, equation, and reference citations 
and sets up files to be printed using Microsoft Word.  The finished document has 
figures, tables, equations, and references numbered consistently in the text and 
includes a reference list in the format you specify.  The reference list can be 
compiled by a search of a database file of references (a bibliography), using a 
Microsoft File database. 
You will find that Scholar's Aid  makes writing documents easier.  You no longer have 
to think about numbering of figures and equations.  Your mind can be on the writing. 
Need a proposal made up of sections from old papers?  Just copy and paste together 
sections from the papers made with Scholar's Aid  and you are ready to renumber 
and make a new reference list.  Once your bibliographic database is big enough, you 
will find that most of your citations are already available for inclusion in new 
documents.  
Need to resubmit a document to a journal with a different reference format?  No 
problem with Scholar's Aid.  
Scholar's Aid  Tutorial 
The following exercise will take you through the preparation of a final draft for a MS-
Word document using Scholar's Aid  to prepare list numbering and references.  
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The Scholar's Aid  program included with this demonstration package is complete 
except for the instruction manual.  See the end of this demostration document for 
information on ordering a complete manual.
These are the files that make up the Scholar's Aid  Shareware package:

1. Scholar's Aid  
2. Scholar's Aid  Tutorial
3. SA Demo Text 1
4. SA Demo Text 2
5. SA Demo New Refs
6. SA, Ref List Format
7. SA Demo Ref File
8. SA Demo Ref File index
9. SA Packing List

Prepare the following disks by copying the files from the Scholar's Aid  package as 
explained below (this example is intended for a minimum system consisting of a 
512K Mac with two 400K disk drives):

1. The "Sys Word Demo" disk containing MS-Word 1.05, a system folder not 
exceeding 240K, and the demo source texts.  Word 3.0 works too, but you'll need an 
800K drive.

2. The Scholar's Aid /MS-File bibliographic database  disk, called "SA Biblio",
containing Scholar's Aid, MS-File, the example bibliographic database file, "SA Demo 
Ref File," the index file, "SA Demo Ref File Index."  
Of course if you have an 800K drive or a hard disk the arrangement can be different, 
but put the files into folders with the names as the disks listed above so that you can
follow these instructions.
Writing the Source Text   
Start up your Mac with the "Sys Word Demo" disk in the internal drive and the "SA 
Biblio" disk in the external drive.  Double-click the "SA Demo Text 1" file to open it for
viewing in MS-Word.  This document is an example source text file that is ready to be
printed in final form.  This is the form in which you will write and edit your document 
before preparing it for final printing with Scholar's Aid.  
"SA Demo Text 1" has references to figures, tables, equations, appendices, lists, and 
bibliographic references as print merge variables or codewords.  Read it to see how 
the codewords are used.  For more information about codewords, register and get 
the Scholar's Aid  Manual.
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Besides the codewords, there are two features to this document that Scholar's Aid  
needs to number lists and references.  These are the print merge INCLUDE 
statements at the beginning and end of the document:
These lines cause the print merge feature of MS-Word to access the files "SA, Set 
Code" and "SA, Ref List Format" to get the print merge commands written by 
Scholar's Aid  to format the numbering and reference list.
Searching the Source Text for Codewords 
When the document is ready to print in a final form with automatic numbering and a 
formatted reference list, save the source text file (in this demonstration, "SA Demo 
Text 1") by clicking Save in the File  menu.  The file name that you use must match 
the name in the «INCLUDE YourTextName, Set Code» statement at the beginning of 
the document.  This name must not contain a comma, nor may it be too long.
Quit MS-Word.  Go to the Finder desktop.  You can check the contents of the 
clipboard by selecting Show Clipboard in the Edit menu. 
Run Scholar's Aid  by double-clicking its icon on the "SA Biblio" disk.  
Scholar's Aid  is set up as a batch processor, which means that you will be presented
with the same screens each time you run the program.  The screens give you a 
selection of buttons to control how the references will be formatted and what the 
next step in the process will be.  
If this is not the first time that Scholar's Aid  has been run on this disk a preliminary 
screen may be displayed, presenting you with two buttons, or choices:  

• Continue setup of source text previously searched
• Start new search of new source text

If this screen is not displayed skip to the next paragraph.  Otherwise click the second
button (Start new ...).
The next screen in Scholar's Aid  allows you to choose whether you want errors to be
printed on the line printer, whether the text will be checked for typo errors (limited 
to checking for repeated words, such as "the the"), or to specify that a reference 
table text file should be processed for input into MS-File.  This last feature allows you
to arrange the author and editor lists in your text file into proper order for 
alphabetical sorting.   
We don't want to use any of these options in this demonstration, so click the OK 
button to continue to the next screen.
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When you are asked which source text file should be searched, respond by double-
clicking the file name, "SA Demo Text 1" on the "Sys Word Demo" disk.  You may 
have to click the Drive button to display the "SA Demo Text 1" file name.  
In the next screen the message, 
"Searching for codewords for figures, tables, ..." 
is displayed briefly, then 

"3  references found.  
Search of source text file complete.  
Click 'Quit' to search Reference Database ....  
If Ref Table already exists, then ...."  
A control panel appears in the upper right corner, with three buttons.

• Quit Causes termination of Scholar's Aid  processing.
• Restart Causes Scholar's Aid  to start batch processing over 

again from the beginning.
• Continue Causes Scholar's Aid  to go to the next step in the 

batch processing.
At this point the text file has been searched and the codewords have been tabulated.
The reference codewords have been written to the clipboard in a form suitable for 
the bibliographic database find list.  We will now quit Scholar's Aid  and start MS-File 
to find the references used in the source text.  Click Quit.
How to Search the Bibliographic Database for References 
After returning to the desktop, you may check the reference codeword search list by 
opening the clipboard (Show Clipboard in the Edit menu).  Don't cut or copy 
anything while the clipboard contains the search list or it will be lost.
Double-click to open the "SA Demo Ref File" on the "SA Biblio" disk.  The 
bibliographic database will open in MS-File.
Open Find from the Organize menu.  Click the Clear button to empty all the fields 
in the Find window.  Click on the Codeword box and Paste in the search list from 
the clipboard.  Then click the Find button.  
When the search is finished the displayed database contains only the references that
were found from the search list.  The rest of the bibliographic database is still intact. 



Scholar's Aid Tutorial (page)
————————————————————————————————

—————————————————————
If you want an alphabetically sorted reference list, you should sort the references 
now using Sort from the Organize menu.  Lists can be sorted alphabetically by 
clicking the Author field first and the Year field second.  This is the default setting 
in the Sort window.  Note that the form of the Author field affects the accuracy of 
the alphabetical sort (last names first and don't use "and").
Now we will save the reference list for use with the print merge feature of MS-Word.  
Choose Save Records as... from the File menu, click as Text (for Print Merge) 
button, and click the Drive button to get the Scholar's Aid  disk.  Type in "Ref Table" 
(this name is required) as the name and click Save.  
How to Compile the Reference Table 
Now we will go back to Scholar's Aid  to finish numbering the codewords and 
formatting the reference list.  Quit MS-File and double-click Scholar's Aid.  
In the first screen, Scholar's Aid  asks if you want to continue with the set up of 
previously searched source or search a new one.  Click the button for "Continue 
setup ...."  
The next screen gives you two options:  

• Printing errors on line printer
• Sort by order in source text

The second option tells Scholar's Aid  to sort the references in the Ref Table in the 
order that reference codewords occurred in the source text (an alternate to 
alphabetical sorting in MS-File).  Click OK when you are ready to continue.
You will see the message, "Checking ...", while Scholar's Aid  checks the reference 
codewords that were found in the source text against the references in the "Ref 
Table" file.  It reports any codewords that were not found in the bibliographic 
database or that were duplicated.    
When the check is completed, continue with the preparation of the "SA Demo Text 1"
file for final printing by clicking the Continue button in the upper-right-hand control 
panel.  
The next screen gives you a choice of reference types:  

• Use numerical order of appearance in reference list. 
• Use author and year. Publication year inserted for ref codeword.

In the first case a reference codeword is replaced by the number of its order in the 
Ref Table (which was previously selected to be alphabetical or by 
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order in text).  In the second case, the reference codewords will be replaced by the 
year of publication.  This reference style is explained further in the Scholar's Aid  
Manual.
The next screen gives you seven options for the format of the author lists to be 
displayed in the reference list when it is printed out.  There are additional options for
the author list appearance which may be added to any of the author sorting formats.
The formatting is also applied to editor fields in the Ref Table.
After you have made your choices, click OK.
The next screen shows the message, "Compiling Reference List. ...," while Scholar's 
Aid  numbers the figure, table, equation, appendix, and list  codewords according to 
the order of their occurrence in the text.  The file with these commands is written to 
the "Sys Word Demo" disk as a text file called "SA Demo Text 1, Set Code".  Scholar's
Aid  also inserts print merge control parameters into the Ref Table records and 
prepares a list of print merge commands for the reference codewords.   A modified 
reference table, called "SA Demo Text 1-Ref-Table", is written to the "Sys Word 
Demo" disk.  If your source text file was in a folder these new files will be placed in 
that folder.
When Scholar's Aid  completes the compilation, it lists the compiled references on 
the screen.  Finally the message "Compilation completed. ...,"  is shown and the 
control panel reappears in the upper right.  Now you are ready to print the final 
document.  Click Quit to return to the desktop.
How to Print the Source Text using MS-Word Print Merge 
If you have gotten to this part of the tutorial without seeing any error messages, the 
"SA Demo Text 1" file is ready to be printed in its final form with numbering supplied 
automatically by Scholar's Aid.
Double-click to open the Word file, "SA Demo Text 1".  
Print the finished document using Print Merge (under the File menu in MS-Word).  
For long documents this is a time-consuming process; but the product is worth it! 
The other files in this package are additional tutorial files that are explained further 
in the Scholar's Aid  Manual.  Don't throw them away.
You may use the "SA Demo Ref File" MS-File database format for your own 
bibliographic database.  Simply open it, delete the demonstration records by 
selecting them and pressing the backspace key, and save the database with a new 
name (use Save Records as... in the File menu).  Now you can enter your own 
references.
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How to Register and Get the Scholar's Aid  Manual 
Scholar's Aid  is shareware.  Pass it around to your friends with the demonstration 
files, upload it to electronic bulletin boards (all rights reserved).  
TryScholar's Aid  for 30 days.  If you like it and continue to use it you must pay $35 
for it.  This fee will register you as an owner of Scholar's Aid  and entitle you to 
upgrades.  I will send you a 35-page, indexed manual explaining in detail how to use 
Scholar's Aid .  The manual contains many hints for using Scholar's Aid  and its 
hidden features.  The manual is available only for registered owners.  To register use 
the order form at the end of this document. 
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Order Form

Name _______________________________________________________
Company  ____________________________________________________
Address _____________________________________________________
City ______________________________ State ____________________
Zip _________________  Country  ________________________________
Phone    ( _________) ________ - ________________________________     
Updates requiring only a disk, $6.  Updates requiring disk and manual, $10.
Product Description EACH QTY TOTAL
Scholar's Aid $35.00 _____ $______ 
SUBTOTAL $__________
Shipping ($1.00 per package) $______
Overseas Air Mail (add $1.50) $______
Sales Tax (Washington Residents Only:  Add 7.9%) $______
TOTAL ORDER AMOUNT U.S. $__________
Check ___ 
Signature ____________________________________________________
Send to 

Stuart Strand
19016 Ashworth Ave
Seattle, Washington 98133



i* Macintosh is a licensed trademark of Apple Computer.  MS Word, MS File, 
and MS Basic are registered products of Microsoft, Bellevue, Wa.


